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 Lab setup guide

Overview

The purpose of this lab setup guide is to assist the classroom preparer in setting up the WD601 
classroom lab environment. 

If you intend to use IBM remote labs instead of manually setting up an environment, do not use this 
guide. Instead, refer to the Training Partner Operations Guide for directions to the IBM Remote Lab 
Platform (IRLP).

If you intend to manually set up an environment, use this guide. It is separated into the following 
parts:

  • "Requirements" on page 3

  • "Network setup instructions" on page 6

  • "Operating system setup instructions" on page 7

  • "Software setup instructions" on page 10

  • "Additional setup" on page 20

  • "Verification procedures" on page 21

The total setup time for this class is approximately <#> hours.

WebSphere Education only: In addition to this guide, you should also consult the appropriate 
operating system setup document. These documents are available in the Course Materials Vault 
under course code WEOSLSG.

Important

The classroom must be ready to run lab exercises before the first day of class. You might want to 
create a virtualized environment that you can maintain and reuse. Test the entire setup thoroughly 
to avoid problems during class time. If you experience problems and need assistance, contact the 
IBM Help Desk:

Toll-Free: 1-888-502-5511 
International: 1-404-238-6000 
Email: insthelp@us.ibm.com
Course materials may not be reproduced in whole or in part 
without the prior written permission of IBM.
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Figure 1.  Illustration of lab environment

"Requirements" on page 3 provides a summary of the classroom setup by using system labels. A 
system label is a name for each unique system included in this classroom setup. The name 
identifies a specific system configuration throughout this document. If an instructor system has the 
same system label as a student system, they have identical setup requirements.

Classroom

Student virtual lab environment
(1 Instructor + 12 Student)

System z guest

Instructor

Lab environment on IBM CLP VPNStudent1

Student2
… (up to 12)

InternetInternet
Virtual 
bridge

http server
Course materials may not be reproduced in whole or in part 
without the prior written permission of IBM.
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 Requirements

The following section provides information about how to manually create the lab environment that is 
needed to conduct the lab exercises in this course. As the classroom provider, you are responsible 
for providing the following configuration for this class. The instructor requires one configuration, and 
each student in the class requires a separate configuration. Depending on the course requirements, 
instructor and student configurations might be identical. 

The total number of systems that are required for a class is the number of instructor systems plus 
the number of students and multiplied by the number of student systems that are required for each 
student. 

1+1
= 2 Example

For instance, if the instructor requires 3 systems and 12 students require two systems each, you 
make the following calculation:

3 instructor systems + (12 students x 2 systems each) = 27 systems for the class

Lab configuration overview

Network requirements

Table 1: Configuration for instructor

System label
Machine type 
and processor

RAM Hard disk
Display 
resolution

Operating system

Instructor
<2.5 GHz or faster 
Core 2 Duo>

<4 GB> <60 GB> <1024 x 768>
Windows Server 
2008 R2 Standard 
Edition SP1 64-bit

Table 2: Configuration for each student

System label
Machine type 
and processor

RAM Hard disk
Display 
resolution

Operating system

Student
<2.5 GHz or faster 
Core 2 Duo>

<4 GB> <60 GB> <1024 x 768>
Windows Server 
2008 R2 Standard 
Edition SP1 64-bit

Table 3: Required network configurations
Network configuration Classroom requirement
Specify isolated networks or a single network. Isolated networks
Specify whether Internet access is required. Required
Specify whether a DHCP server is required. Required
Course materials may not be reproduced in whole or in part 
without the prior written permission of IBM.
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Software requirements

Obtain the following software before starting classroom setup. IBM software is available from IBM 
PartnerWorld at www.ibm.com/partnerworld. The classroom provider is responsible for obtaining 
software licenses for any non-IBM software.

Host or server system requirements

This section does not apply to this course.

IDs and passwords

Table 6 lists the various IDs that IBM suggests for this class and any requirements that they have. 
Some might be automatically created during the installation process.

Specify whether fixed IP addresses should be 
assigned.

Not necessary

Specify whether promiscuous mode is required. Not necessary

Table 4: Required software for class

Software product Version Operating systems
System labels that 
require software 
product

<Microsoft Windows Server 2008 R2 
Standard Edition>

SP1 64 bit
Instructor,
Student

Oracle JDK 7
update 45 or 
later

Windows 2008 64 bit
Instructor,
Student

IBM DB2 9.7 Windows 2008 64 bit
Instructor,
Student

Eclipse Kepler (4.3) Windows 2008 64 bit
Instructor,
Student

Mozilla Firefox 17 or later Windows 2008 64 bit
Instructor,
Student

IBM Installation Manager 1.6.2 Windows 2008 64 bit
Instructor,
Student

WebSphere Application Server ND 8.5 Windows 2008 64 bit
Instructor,
Student

Worklight Server 6.1 Windows 2008 64 bit
Instructor,
Student

Android SDK 4.4 (API 19) Windows 2008 64 bit
Instructor,
Student

Table 5: ID names and login information
ID User name Password Comment
WebSphere Application 
Server

wasadmin was1edu

Table 3: Required network configurations
Network configuration Classroom requirement
Course materials may not be reproduced in whole or in part 
without the prior written permission of IBM.

4 Mobile Application Development with IBM Worklight © Copyright IBM Corp. 2014

www.ibm.com/partnerworld


Lab Setup Guide 
V9.1

LSG
DB2 db2admin Web1sphere
Worklight worklight Web1sphere

Table 5: ID names and login information
ID User name Password Comment
Course materials may not be reproduced in whole or in part 
without the prior written permission of IBM.
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Network setup instructions

This section does not apply to this course.
Course materials may not be reproduced in whole or in part 
without the prior written permission of IBM.
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 Operating system setup instructions

Perform the following steps to install and customize the base operating system for each system in 
the class setup.

Instructor

__ 1. Follow the instructions for Student.

Student 

Create a user that is named worklight with administrative privileges and password of worklight.

__ 1. Click Start and select Administrative Tools > Active Directory Users and Computers.

__ 2. Open the domain name that you require, wetraining.com, and right-click Users.

__ 3. Select New > User.

__ 4. In the New Object - User dialog, type the following information:

__ a. Last name: worklight (Full name is filled automatically)

__ b. User logon name: worklight

__ 5. Click Next.

__ 6. For password, type Web1sphere in both fields.

__ 7. Check only Password never expires.

__ 8. Click Next and Finish.

__ 9. Close the Active Directory Users and Computers dialog.
Course materials may not be reproduced in whole or in part 
without the prior written permission of IBM.

© Copyright IBM Corp. 2014 Lab setup guide 7



Lab Setup Guide 
Set up folder permissions

__ 1. Open a Windows Explorer.

__ 2. Click Local Disk (C:).

__ 3. From the Organize menu, select Folder and search options.
Course materials may not be reproduced in whole or in part 
without the prior written permission of IBM.
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 __ 4. Click the View tab and change the settings as follows:

  • Display the full path in the title bar (Classic theme only): Checked
  • Hidden files and folders: Select Show hidden files, folders, and drives 

__ 5. Close the Folder Options dialog.

Copy the lab files

__ 1. Extract WD601_ERC1.0_LABFILES.ZIP to C:\.

__ 2. Verify that there is now a C:\LabFiles folder, which includes three subfolders: Resources, 
Software, and Solutions.
Course materials may not be reproduced in whole or in part 
without the prior written permission of IBM.
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Software setup instructions

Perform the following steps to install and customize software that is required in addition to the 
operating system. 

Instructor

__ 1. Follow the instructions for Student.

Student

Install Oracle JDK 7

__ 1. Download the JDK from the Oracle download site at: 
http://www.oracle.com/technetwork/java/javase/downloads/index.html 

Note

Make sure that you install the latest version of JDK 7.

__ 2. Follow the installation instructions at: 
http://docs.oracle.com/javase/7/docs/webnotes/install/index.html 

__ 3. Create the PATH variables:

__ a. Click Start, and then right-click Computer and select Properties.

__ b. Click Advanced system settings > Environment Variables.

__ c. Under System variables, scroll down to Path.

__ d. Select Path and click Edit...

__ e. Scroll to the end of the Variable value field and add the following (including the leading 
semi-colon (;)
;C:\Program Files\Java\jdk1.7.0_xx\bin

Note

For the xx, substitute whatever version number you downloaded (at the time of writing, the latest 
number was 51).

__ f. Click OK three times to close the dialogs.

Install Eclipse Kepler (v4.2)

__ 1. Download the Eclipse IDE for Java EE Developers Windows 64-bit from the project 
download site at: http://www.eclipse.org/downloads/packages/release/kepler/sr2
Course materials may not be reproduced in whole or in part 
without the prior written permission of IBM.

10 Mobile Application Development with IBM Worklight © Copyright IBM Corp. 2014



Lab Setup Guide 
V9.1

LSG
 __ 2. Extract the compressed file that is called eclipse-jee-kepler-SR2-win32-x86_64.zip 
to: C:\

__ 3. Create a shortcut to C:\eclipse\eclipse.exe, and place it on the Windows desktop. 
Name it: Eclipse - Juno

Install Firefox (v17 or later)

__ 1. Open an Internet Explorer browser window to: 
http://www.mozilla.org/en-US/firefox/new/

__ 2. Click Firefox Free Download.

__ 3. Follow the instructions that are provided on the page to download and run the Firefox setup 
wizard.

Install IBM Installation Manager (v1.5.3)

__ 1. Download the IBM Installation Manager archive file 
InstalMgr1.6.2_WIN_X86_WAS_8.5.5.zip (part number CIK26ML) and extract it to: 
C:\IBM Installation Manager

__ 2. Open a command prompt to the directory where you extracted the compressed file and run 
the command: install.exe

__ 3. Follow the installer wizard pages and accept the default values to install Installation 
Manager.

__ 4. When the installation is complete, close all windows.

Install DB2 Enterprise Server Edition (v9.7)

__ 1. Download DB2_WSE_97_Win_x86-64.exe (part number CZ1IDML). 

__ 2. Double-click the .exe file to launch the self-extractor.

__ 3. From the DB2 product package location, run setup.exe to launch the DB2 Setup 
Launchpad.

__ 4. In the Welcome page, select Install a Product.

__ 5. In the Install a Product page, under DB2 Workgroup Server Edition Version 9.7, click Install 
New.

__ 6. In the DB2 Setup wizard’s Welcome page, click Next.

__ 7. Accept the agreement terms and click Next.

__ 8. Select Typical as the installation type and click Next.

__ 9. Select Install DB2 Workgroup Server Edition on this computer and click Next.

__ 10. Accept the default installation folder (C:\Program Files\IBM\SQLLIB\) and click Next.

__ 11. Accept the default values for Domain (None - use local user account) and User name 
(db2admin), and type Web1sphere in the Password and Confirm password fields (note the 
uppercase “W”).

__ 12. In the Configure DB2 instances page, make sure that DB2 is selected and click Next.

__ 13. In the Prepare the DB2 tools catalog page, click Next (do not select the check box).
Course materials may not be reproduced in whole or in part 
without the prior written permission of IBM.
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__ 14. In the Set up notifications page, clear the Set up your DB2 server to send notification 
check box and click Next.

__ 15. In the Enable operating system security for DB2 objects page, clear the Enable operating 
system security check box and click Next.

__ 16. In the Start copying files page, click Install. The installation process is started.

__ 17. In the Setup is complete page, click Finish.

__ 18. Close the First Steps window.

Verifying the DB2 installation

__ 1. Open a command prompt and navigate to C:\Program Files\IBM\SQLLIB\BIN.

__ 2. Type the following command: db2val
After a moment you see a report:

__ 3. The DB2 installation was successful. Close the command prompt.

Creating the Worklight Server databases

Create the WRKLGHT core and WLREPORT reporting databases, and also the APPCNTR 
database. Grant CONNECT permission to them to the worklight user ID. A script that you can run 
by using the DB2 Command Line Processor is provided to create the databases.

__ 1. Open a DB2 command window: Click Start and select All Programs > IBM DB2 > 
DB2COPY1 (Default) > Command Line Tools > Command Window.

__ 2. In the DB2CLP command window, type the following command to execute the 
CreateDatabases.txt script in the <software> folder:

db2 –vf <software>\CreateDatabases.txt

__ 3. Wait until the script completes execution, which can take up to 10 minutes. When it is 
finished, the DB2 command window displays the successful completion messages that are 
shown here. 
Course materials may not be reproduced in whole or in part 
without the prior written permission of IBM.
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Note

If there is a problem with running the script, you can type (or paste) the lines one at a time into the 
prompt. 
Course materials may not be reproduced in whole or in part 
without the prior written permission of IBM.
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__ 4. Close the DB2 command window.

Install WebSphere Application Server Network Deployment (v8.5)
__ 1. Download the three parts for IBM WebSphere Application Server Network Deployment 

V8.5 for Multiplatform Multilingual. Part numbers are CI6Y3ML, CI6Y4ML, and CI6Y5ML, 
and the archive file name is WAS_ND_V8.5_X_OF_3, where X is 1, 2, or 3.

__ 2. Extract the three archive files to: C:\WAS_install

__ 3. Open Start > All Programs > IBM Installation Manager, and click IBM Installation 
Manager.

__ 4. Open File > Preferences.

__ 5. In the left pane, verify that Repositories is selected; then click Add Repository.

__ 6. In the dialog that appears, click Browse.

__ 7. Navigate to the files you extracted and open the folder C:\WAS_install\disk1.

__ 8. Select diskTag.inf and click Open.

__ 9. Click OK to return to the Preferences dialog.

__ 10. Verify that the repository is recognized by clicking Test Connections. You see a 
confirmation dialog:

__ 11. Click OK twice to close the preferences window.

__ 12. In the Installation Manager window, click Install.

__ 13. In the Install Packages page, check the box for IBM WebSphere Application Server 
Network Deployment:

__ 14. Click Next.

__ 15. Accept the terms in the license agreement and click Next again.

__ 16. Verify that the Shared Resources Directory path points to C:\Program Files 
(x86)\IBM\IMShared. You can ignore the waning about the administrative privileges.
Course materials may not be reproduced in whole or in part 
without the prior written permission of IBM.
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 __ 17. Click Next.

__ 18. Click Next on the page for the new package group.

__ 19. In the Select the translations to install page, only English should be selected (the default). 
Click Next.

__ 20. In the second Select the features to install page, accept the defaults and click Next.

__ 21. You are now to the Review the summary information page:

__ 22. Click Install. 

__ 23. In the following package was installed page, make sure that Profile Management Tool to 
create a profile is selected (the default selection) and click Finish.

__ 24. In the Profile Management Tool in the WebSphere Customization Toolbox 8.0 window, click 
Create.

__ 25. In the Environment Selection page, verify that Application server is selected and click 
Next.

__ 26. In the Profile Creation Options page, verify that Typical profile creation is selected and 
click Next.

__ 27. In the Administrative Security page:

__ a. Select Enable administrative security.

__ b. Type wasadmin in the User name field.

__ c. Type was1edu in the Password and Confirm password fields.

__ d. Click Next.

__ 28. In the Profile Creation Summary page, click Create.
Course materials may not be reproduced in whole or in part 
without the prior written permission of IBM.
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__ 29. In the Profile Creation Complete page, verify that the Launch the First steps console box 
is checked and click Finish.

__ 30. The new profile is listed:

__ 31. Close the dialog.

Verifying the WebSphere Application Server installation

__ 1. In the First steps console, click Installation verification. The server1 server in profile 
AppSrv01 is started, and a number of verification tests are executed. You see the following 
(at the end of a long list of reports) when the test is completed:

  • >ADMU3200I: Server launched. Waiting for initialization status.

  • >ADMU3000I: Server server1 open for e-business; process id is xxxx.

  • Server port number is: 9080

  • IVTL0010I: Connecting to the ws2008r2x64 WebSphere Application Server on port: 
9080

  • IVTL0015I: WebSphere Application Server ws2008r2x64 is running on port: 9080 for 
profile AppSrv01

  • Testing server using the following...

  • … (several other lines of tests)

  • IVTL0070I: The Installation Verification Tool verification succeeded.

  • IVTL0080I: The installation verification is complete.

__ 2. Close First Steps.

Install Worklight Server Version 6.1

__ 1. The Worklight Server is also installed through the Installation manager. Extract 
imf_6.1.0.offering.disk1.zip to any convenient place.

__ 2. In the Installation Manager, click File, and select Preferences.

__ 3. Click Add Repository; then Browse to <unzipped> > Worklight > disk1.
Course materials may not be reproduced in whole or in part 
without the prior written permission of IBM.
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 __ 4. Select diskTag.inf and click Open.

__ 5. Click OK to return to the Preferences window.

__ 6. Verify that the repository can be read correctly by clicking Test Connection. 

__ 7. Close the Test Connection dialog and the Preferences window by clicking OK twice.

__ 8. Back in the Installation Manager, click Install.

__ 9. There are now 10 dialogs to respond to. Click Next after each step:

1) In Select packages to install, select IBM Worklight Server.

2) In the Licensing agreement, select I accept the terms...

3) Verify that Create a new package group is selected, and that the installation 
directory path is C:\Program Files\IBM\Worklight.

4) There is only one feature to install. Accept the default.

5) Verify that Yes is selected for Install the IBM Application Center.

6) Select IBM DB2.

7) For the DB2 database settings, type the host name localhost and then Browse to 
C:\Program Files\IBM\SQLLIB\java and select db2jcc4.jar. Click Open.

8) In Database server additional properties, type: user name worklight and 
password Web1sphere

9) Click Next three times.

10) Select WebSphere Application Server.

11) Browse to the installation directory at C:\Program Files (x86)\IBM\WebSphere\ 
AppServer and type the Administrator password: was1edu

12) For the operating system user name, keep the default WETRAINING and type: 
worklight

13) Click Next twice, and then Install.

__ 10. Close the Installation Manager.

Verify the installation of the Worklight Server

__ 1. Open a browser to https://localhost:9043/ibm/console (WebSphere Integrated 
Solutions Console).

__ 2. Log on as wasadmin, with password was1edu.

__ 3. Navigate to Applications > Application Types > WebSphere enterprise applications.

__ 4. Verify that you can see these two applications:

  • IBM Application Center Console

  • IBM Application Center Services

__ 5. Type the URL: http://localhost:9080/appcenterconsole

__ 6. Verify that the Application Center opens.
Course materials may not be reproduced in whole or in part 
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Install Derby (v10.9 or later)

__ 1. Download the Derby compressed file from: 
https://db.apache.org/derby/derby_downloads.html

__ 2. Click the link for the latest official release.

Note

At the time of writing, the latest version was db-derby-10.10.1.1-bin.zip.

__ 3. Click db-derby-10.10.1.1-bin.zip and Save the file.

__ 4. When it finishes downloading, right-click the file and select Open Containing Folder.

__ 5. Right-click the file in its folder and select Extract All...

__ 6. Change the directory to C:\ and click Extract.

__ 7. The files are extracted to a folder that has the same name as the archive file (in this case, 
db-derby-10.10.1.1-bin). Change this name to: Derby

__ 8. Open Derby > bin and highlight startNetworkServer.bat and stopNetworkServer.bat.

__ 9. Right-click and select Send to > Desktop (Create Shortcut).

__ 10. Drag the two shortcut icons to the desktop.

__ 11. Rename them: startNetworkServer and stopNetworkServer

__ 12. Create an environment variable for Derby.

__ a. From the Start menu, right-click the Computer icon and select Properties.

__ b. Click Advanced system settings.

__ c. Click Environment Variables.
Course materials may not be reproduced in whole or in part 
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 __ d. Under System variables, click New.

__ e. Add the variable name DERBY_HOME and the value C:\Derby.

__ f. Click OK.

__ g. Select Path and click Edit.

__ h. At the end of the path, add ;C:\Derby\bin;C:\Derby\lib (do not forget the leading 
semicolon).

__ i. Click OK three times to close the dialogs.

__ j. Close the control panel.

Create the worklight-training database

__ 1. Double-click the Eclipse Juno shortcut on the desktop. When the workspace Launcher 
dialog appears, type C:\db_install\workspace and click OK.

__ 2. Close the Welcome view.

__ 3. Right-click in the Project Explorer and select Import > Import...

__ 4. Expand General and select Existing Projects into Workspace.

__ 5. Click Next.

__ 6. Click Select archive file; then browse to <software>\Create_Derby.zip, and click Open.

__ 7. Click Finish. The project appears in the Explorer view.

__ 8. Expand CreateDB > src > derby.setup.

__ 9. Right-click DBSetup.java and select Run As > Java Application.

__ 10. Open the Console view. You should see: a list of executed files, followed by a statement that 
n SQL statements were executed, and finally, a read test that returns all the values that 
were written to the tables (accounts, account transactions, and users).

__ 11. Close Eclipse.
Course materials may not be reproduced in whole or in part 
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Additional setup 

This section does not apply to this course.
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without the prior written permission of IBM.

20 Mobile Application Development with IBM Worklight © Copyright IBM Corp. 2014



Lab Setup Guide 
V9.1

LSG
 Verification procedures

Use the following information to verify the installation and configuration of the student and instructor 
lab environments.

Instructor

__ 1. Follow the same instructions as for Student.

Student

__ 1. To verify the installation, run Exercise 1 on one computer. 

Testing the lab exercises

Complete all of the lab exercises in the Student Exercises Guide provided with the course, and 
verify that they produce the expected results.

The instructor, or someone else with skills in the products that are involved, should conduct these 
tests; the lab setup technician might not be qualified. 

Important

You should completely verify all of the lab exercises whenever you build the environment as 
described in this document. If you create the environment by restoring a backup copy, you should 
run enough of the exercises to demonstrate that the copy was properly restored.

The lab exercises were tested in the development environment that is described in this guide. You 
should test each exercise in your own lab environment to confirm the setup. Failure to complete an 
end-to-end test of the labs might result in unexpected behavior during class.

Be sure to allocate enough time to complete these instructions. The classroom must be ready to 
run lab exercises before the first day of class.

Performance notes

Verify that every lab workstation meets or exceeds the minimum hardware requirements. 
Insufficient processor speed, memory, or disk space can affect the performance of the lab system.

Consider shutting down any running software on the workstation that is not needed or might be 
using system resources.

Security or anti-virus software can affect system performance, especially during the installation of 
the environment.
Course materials may not be reproduced in whole or in part 
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Firewalls or proxy servers in the network can cause connectivity and performance issues. If 
possible, consider disconnecting the lab workstations from the network. 

Disconnect any open file shares, external USB drives, or disks that are connected to the 
workstation.
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