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1- Open the software.  

I- Working with ENVI 

2- From  “File/open image file” open the files of the 7 bands of “Scene-173-44 ETM

 

”: 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

3- The pannel of the “Available band list” will be opened showing the list of the 
bands opened in the software. 
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4- Activate the   

 
5- Select bands:   the  band combination 

7 & 4 & 2 . where  
Band 7  for  R   (red) 
Band 4  for G   (GREEN) 
Band 2  for  B   (BLUE) 
 
 
 
 
 
 
 
 

 
 
6- press “Load RGB” 

 
 
 

7- This will open  three pannels. 
The lower left one is the Scene  
image of band combination 
  7 / 4 / 2. 
The other two bannels are two  
levels of zoom. 
Pressing at any part in the 
scene in the lower left pannel 
will display the zoomed image 
of  this part in the other two 
pannels. 
Pressing at any point in the 
upper pannel will show a more 
zoom of the point in the lower 
right pannel. 
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8- Try to Enhance the image by using  

“Enhance/[image] Linear 2%”. 
 

9- Try other enhancment types. 
 
 
 
 
 
 
 
 
 
 
 
 

10- Try other band combinations such as (3, 2, 1  natural color)   or any other 
combination you want. You will find that the best one for geologic 
discrimination is 7,4,2 for R,G,B. 

 
11- Notice: in the pannel of the “Available band list” 

Each band is associated with “Map Info” item, 
which contain the type of projection and datum, 
pixel resolition, and the coordinates of the upper 
left corner of the image in geographic and UTM 
coordinates.  
To see these parameters, just press the + sign in 
front of the  “Map Info” item. 
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II- Layer Stacking (grouping all bands in one file) 

- The process of stacking is to group all bands in one file.  

- You cannot form a band combination from files of different resolutions.  

- If you try to form a band combination from bands (6, 5, 3), the software will not 
accept that, because the resolution of band 6  is 60 m and bands 3 & 5 are 30 m. 

- To solve this problem you can make a stack file (grouping all bands in one file). 
During the process of stacking the software make all bands to be of the same 
resolution, and will raise the files of lower resolution to the higher resolution, 
but without any enhancement of details. 

- Stacking bands (1,2,3,4,5,7,61,62) will produce a stack file containing all bands 
and the resolution of the thermal bands (61 and 62)  will be 30m. 

- After stacking, you can make any band combination including band (6). 

- Use the bands of “Scene-173-44 ETM” given to you in the previous section.  

The steps of making a stack file is as follows: 

1- Open bands (1,2,3,4,5,7, 61, and 62) in Envi. 
2- In the main menu of the program, go to 
 

“Basic tools/ Layer stacking” 
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3- This will open the following dialog box. 
 

 
 

1- Press “Import file” . The list of the opened files  in the “Available bands 
list” appears. Select the files to be stacked. 

2- Select “Exclusive range …..”, 
3- Check on the (coordinate system, Datum, Zone, and resolution) if they 

are correct. The scene given to you is of coordinate system (UTM), 
Datum (WGS84), Zone 36 N, resolution must be 28.5. 

4- Choose if you want to save the resulte as a file directly, or get the results 
in the memory and you can save it later. 

5- If you choose to get the results in a file directly, you had to give a file 
name and where to save the file and press “ok”. 

 

The saved stack file will 
be in the format of “Envi standard”. This file type has no extension and 
could not be opened in any software except Envi. 

Open the saved stack file in the “Available bands list”. You will find that the files 
chosen to be stacked are represented as layers in the stack file (see the 
following figure). 

 

It is important to note that, the name of each layer in the 
stack includes the name and number of the original file intered into the stack. 
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4- If you Choose to get the results in the memory

 

, press “ok”. The following box 
apears. Select “memory” again and press “ok”. 
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5-The stack file will appear in the “Available band list” dialog box as a memory 
layer containing all bands. 

 
 
6- Now you can save the memory layer of the 

stack file. Go to the main menu

 

 of the 
sotware,  point to “save file as/ Tiff-Geotiff”. 
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7- The following box appears. Select the memory layer as input file . 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
When you select the input file an additional part will appear in the dialog box 
concerned with making a subset of the scene. If you want to make a subset use 
the “spatial subset” icon. If not press “ok”. 
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8- The following box appears. choose the file 

name and location to save the stack file. 

 
 
 
 
9-Open the saved file in the “Available bands list”.  

 

It is important to note that, the name of each layer in the stack file does not 
include the name and number of the original files intered into the stack. The 
bands ar numbered in sequence does not related to the original band 
number. So, to use these bands in band combination, you had to put in mined 
the original sequence of bands intered in the stack (band numbers). 
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III- Subset (saving a part of the scene) 

1- Construct a band 
combination (7,4,2) from 
the provided scene “Scene-
173-44 ETM”. 

I- Subsetting an image loaded in the display: 

 
 
 
 
 
 
 
 
 
 
2- In the zoom window, Point to “File/save image as/image file”. 
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3- The following dialog box appears: 
 
 
 
 
 
 
 
 
 
 
4- Press the “Spatial subset” icon.  

The following dialog box appears: 
 
5- Three methods for subset can be used: 

1- 
2- 

By Image. 

3- 
By Map. 
By file

 
. 

1- Subset By Image
- press “image”, the subset by image 

:  

box appears, with a red rectangle 
inside. Drag the rectangle from its 
corners to fit the area you want as a 
subset.  

- Press “ok” to return to the previous 
box, then press “ok” to return to the first 
box. 

- In the first box define the file format as Tiff, 
and the output result as file, and define the 
output file name and the loation to save. 
Then press “ok”.  The subset will be saved. 
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2- 
- To use this method you must have the 

Subset By Map:  

coordinate of the upper left and lower right
corners of the subset area.  

 

- Press “Map”, the subset by Map box appears. 
- In this box the coordinate system is defined in 

the upper rectangle, and the coordinates of the 
Upper left and Lower right corner of the scene 
are  given. 

- These coordinates are given in UTM system. 
- If you have the coordinates if the subset area in 

UTM, insert the values of the upper left and 
lower right corners directly in their 
respective rectangles.  

- If you have the coordinates in geographic 
system as latitudes and longitude s, you 
must press the             icon to change the 
coordinate fields to Lat and long, then 
insert their values .  

- Press “ok” to return to the previous box, 
then press “ok” to return to the first box. 

- In the first box define the file format as 
Tiff, and the output result as file, and 
define the output file name and the 
loation to save. Then press “ok”.  The subset will be saved. 
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3- Subset By file
- If you have an image or map of the area you want to subset, you 

can use this file to define the boundaries of this area. You can 
use the file attached in your data “file for subset boundary.tif”. 
This file is a black and white image for a certain area within the 
scene. 

: 

- This file must be opened in Envi before using it in the subset 
process. 

- Press “File”, the subset by File box 
appears. 

 
 
 
 
 
 

- Press on the file you want to use for 
subsetting.  
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- Press “ok” to return to the previous box, then 
press “ok” to return to the first box. 

- In the first box define  

1- the file format in the “output file type” box 
as Tiff .  

2- the output result as “file”.  

3- Choose  the output file name and the loation 
where to save the file. Then press “ok”.  The 
subset will be saved in the spicified location. 

- You can save the file into memory to see the 
resulted subset. The file will be opened in the 
“available bands list” box as memory file.  To 
see the results load the file in a new display.  
You can save the file in the regular way .  
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1-  Use the stack file you 
produced in the previous 
section. 

II- Subsetting a Stack file: 

 
 
 
 
 
 
 
 
 
 
2- In the main menu of the program

 

, press “file/save file as/Envi 
standard”.    
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3- The “New file dialog” box appears. Press on 
import file. 

  
 
 
 
 
 
 
 
 
 
 
 
 
4- The “create new file input file” 

dialog box appears. Highlight  the 
stack file. Press on the “spatial 
subset” button.  

 
 
 
 
 
5- The “select spatial subset” box appears. You 

can make the subset as described before (by 
image, map, or file). 

 
6- Save the file as described before. Or save to 

memory then save into file as described 
before. 
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IV- Band Ratios 
 

1- 
The Ratios to be applied on the attached files “stack-1 and attack-2” are: 

2- 
Start first with 7,4,2 on the file stack-1 

A-         5/7   -   5/4   -   3/1    for R,G,B 
Form the following ratios and compare with 7,4,2 

B-        5/7   -   4/5   -   3/1     for R,G,B 
3- Repeat the same process on the file stack-2 

1- Open the stack file in ENVI. 
Procedure: 

2- Form the band combination 7,4,2 and save the result as tiff file. 
3- From the main menu of ENVI go to: 

Transform / band ratio 
 
 

 
 
 
 
 
 
 
 
 
 
 
 

4- The “band ratio” box will be opened: 
To inter 5/7 ratio 
Press on band 5.This will inter this band in the  
numerator rectangle. 
Press on band 7.This will inter this band in the  
denominator rectangle. 
Press “inter pair” to inter the pair in the  
“Selected ratio pair field”. 
Repeat the process with other ratios 5/4 and 3/1. 

5- If you want to remove the ratio before entering it,  
use the button “clear”. 

6- If you want to remove a ratio from the  
“Selected ratio pair field”, use the button “delete”. 
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7- If you want to delete all entered data use “clears all”. 
8- Press “ok”. The following box appears; choose memory and press “ok”. 

 
 

 
 
  
 
 
 
 
 
 
 
 
 
 
 
 
 
 

9- A memory layer is created in the  
“available band list” box, containing three 
bands representing the three ratios used. 
 

10- Use the three layers for RGB and load the 
image. 

11- Then save the result as tiff file from 
the image zoom window. 

12- Compare the results of band ratios 
with the previously saved 7,4,2 file to 
see the advantage of the band ratio 
processing.   
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V- Geologic interpretation

Interpretation of dipping beds, folds, faults and 
lithologic contacts
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Horizontal sedimentary bedding
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The effect of weathering on the outcrop pattern of beds 
(map view) Notice the effect of erosion on the outcrop of 
beds (V shapes) 
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Oblique aerial photograph of horizontal layers
Notice the V shapes in bedding along the small valleys  
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Google earth satellite image of horizontal layering
Notice the  river and its deep erosion in the beds
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Google earth satellite image of horizontal layering . Zoom on part of the 
previous photo . Notice the V shapes in bedding  across valleys in 
different parts of the image.  This detailed Outcrop pattern can only 
be seen at very high resolution images.
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Sedimentary layers dipping  at high angle
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Dipping sedimentary layers
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V-shape Rule
The blocks explain the effect of topography on the map view of  beds. V 
shapes are formed 
in the bedding planes across valleys (in horizontal, dipping, and vertical beds).
In general, On the map view, the V shape formed in the outcrops of dipping 
beds across  valleys points towards the dip of beds. So, this feature can be 
used in satellite images to determine the direction of dip of dipping beds.
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Note
• All the following satellite image are extracted from 

Google Earth at different resolution. 
• The scale is drawn on each image.
• These images are in natural color 3,2,1 for R,G,B.
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Dipping beds
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Cenozoic sedimentary succession, Pakistan. Try to see the satellite 
image as a 3D view. Based on the V shape rule, the beds are dipping 
inward defining a synclinal fold. 
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Satellite image of Cenozoic sedimentary rocks, Iran, folded in 
a complex pattern. Notice, the V shapes in bedding at the lower 
left side of the image.  
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Cenozoic folded salt beds, Iran.
Notice, the dip of beds at the lower part of the satellite image
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Complex folding in Cenozoic sedimentary rocks, Pakistan.
Notice, the V shapes in bedding inside the structure, 

indicating a basin structure.  
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Lithologic contacts
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Cenozoic Sedimentary rocks, Iran. Notice, The variation in tone 
and color between the different units. The contacts inbetween
can be easily traced.
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Satellite image of folded sedimentary layers intruded by granite. 
Notice the sharp contact inbetween. Jurassic rocks, Iran.
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Cenozoic folded sedimentary rocks, Pakistan. The rock units 
are clear and can be easily mapped
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Jurassic succession dipping east. Iran.
Notice the V shapes formed in the bedding planes.  

Width of the image is about 500 m. 
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Faults

Page 41



Highly faulted rock succession. Eocene, Pakistan
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Master and minor faults. Jurassic, Iran
Notice the dragging of bedding along the master fault.
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Intensive faulting  in more than one trend realated to the same 
phase of deformation.Faults cam be easily interpreted and mapped. 
Cretaceous, Pakistan
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Folds
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Anticlinal Fold in sedimentary succession. Notice, the direction of 
plunge to the SW, and the V shapes in the northern limb. Width 
of the image= 5 Km.
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Disharmonic folding in Salt dome, Cenozoic, Iran
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Synclinal fold Jurassic rocks, Iran. Notice, the variable intensity of 
erosion of the different beds due to the variation in its competency.
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Major folding, Cretaceous, Pakistan
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Major folding, Oligocene, Afghanistan. The dip of beds can not be 
determined in the image and must be checked in the field.
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Folding in Eocene rocks, Afghanistan
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Folding in Triassic rocks, Iran.
Notice some faults at the middle and southern part of the image
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Folding in Jurassic rocks, Pakistan. 
Notice the sharp hinges of the olds
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Double plunging anticline in Miocene rocks, Iran.
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Double plunging tight anticline, Miocene, Iran.
Notice, the V shapes in the southern limb.
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Basin structure, Eocene, Pakistan. For details, see the next slide.
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Close up view of inner part of the basin shown in the previous slide.
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Complex folding, Cretaceous, Iran
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Refolded folds
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Refolded fold. Miocene, Iran
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Refolded fold. Eocene, Iran.
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Refolded fold.  Cretaceous. Pakistan. 
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Refolding in Jurassic rocks, Iran.
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Faulted folds
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Intensive faulting in Eocene, Pakistan.
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Two conjugate faults affecting a major fold. Jurassic, Pakistan
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Two conjugate faults affecting double plunging folds. Jurassic, Iran.
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Faulting along NE and NW trends. Jurassic, Iran.
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An asphaltic road running along a fault plane affecting a refolded fold. 
Jurassic, Iran.
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An asphaltic road running along a part of a fault affecting a major fold. 
Jurassic, Iran.T he previous slide constitutes the eastern part of the 
present image.
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Major folding and faulting in Triassic Rocks. Iran.
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zoom of the previous image
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Transverse faults affecting major folds. Pliocene, Iran.
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A fault marked by the discontinuity of structures on broth sides 
of the fault. Pliocene, Pakistan.
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A fault cutting oblique to the fold axial plane. Cretaceous, Iran.
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Bsement rocks
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Several granitic masses intruding the metavolcanics. Eastern Desert, 
Egypt. Width of the image is about 60 km.
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Zoom of the previous image. Gabal Kadabora granite intruding 
metavcolcanics. The width of the granitic mass is about 22 km. 
The elongated lines in the granite are dykes. Notice, the sharp 
contact and the younger faults affecting both units.
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Zoom on the previous image, showing the dykes affecting the granite.

Page 79



Miocene sediments within the Basement rocks preserved along a fault plane.
Eastern Desert, Egypt.
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Miocene sediments within the Basement rocks preserved along a fault plane.
Eastern Desert, Egypt.
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Refolded fold in  psammitic gneisses. Hafafit area, Eastern Desert, Egypt.
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Notice. The two masses of  clouds (white small areas) and their black 
shadow on the ground. The two black spots on the central part of the 
image do not indicate lithologic variation. 
The width of the image is about 1 Km.
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This process is to combine the color-composite (false color) TM 
image of resolution 30 m with another monochromatic image of 
higher resolution (e.g. band 8 TM image of resolution 15 m). This 
will produce a new image of the same color variation as the TM 
false color image and has the higher resolution of  band 8  (15 m). 

VI- Merging of images (Data Fusion)  

1- You are provided with two files: 

Procedure:        

a- ###-Stack 3
selected area. the file is an Envi standard file (has no 

 :  is a stack file containing  6  TM bands of a 

extension) 
b- Band 8.tif 

represented in the stack file. 
:  is a tiff  file  containing band 8 of the same area 

2- Open the two files in Envi.  The two files appear in the “Available 
bands list” box. 

3- Then Load the band combination 7,4,2 from the stack file and 
make your enhancement to get the best image. The image will 
be shown in a display number #1. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Page 84



 
4- Open a new display window to load (band 8) in it as follow:  

Press “Display / New Display”. This opens a new empty 
display window (#2).  
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5- Load band 8 in the new window. To do this:  

a- Select the file “band 8.tif”  
b- select “Grey Scale” (because band 8 is monochromatic)   
c- Press the button “Load band”.  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
6- This will load band 8 in the new display window. Now, you have the two images (7,4,2 image 

and band 8 image) loaded in two separate widows (Window #1 and #2). Make enhancement 
on band 8 image for best result.  
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7- Now you are ready start the process of merging the two images. 

8- Press “Transform / Image sharpening / HSV” 
 

 
9- The “select input RGB” box appears. Select (Display  #1

 

) because it 
contains the RGB image. Press “ok”. 

 
 
 
 
10- The “High resolution input file” box appears. 

Select bad 8.
The option to take a spatial subset is available 
in this box. You can use it if you need before 
you press ”ok”.  

 Then press “ok”.   

 
 
 
 
 
 
 
 
 
 
 
 
 
 

Page 87



 
 
11- The “HSV sharpening Parameters” box appears. Select 

“Memory”. Press “ok”. 
 
 
 
 
 
 
 
 
 
 
 
12- In the next box, select “Memory” again. Press “ok”. 
 
 
 
 
 
 
 

 
13- In the “Available bands list” box a new layer is added 

(Memory 1

 

) consists of  3  bands. These three bands are 
automatically loaded as RGB. 
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14- Open a new blank display (Display #3) to load the result (Memory 1) in it. 
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15- Press “load RGB”.  The new merged image will appear in (Display #3). Make the necessary 
enhancement. 

 

 
 

16- If the result is ok, you can 
save the merged file from the 
menu of (Display #3). 

File / save image as / image file 

Choose to save the output file as  
a tiff file, and choose the location 
where to save the file. Press “ok”. 

In this box, the option to take a 
subset is also available for use.  
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17- Compare the resulted merged file with the 7,4,2 file. You will find that the new image has 

the same color composite as that of the 7,4,2 file, but has a larger pixel size (i.e. objects are 
larger in size in the new image) 
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1- Open the two images to be mosaicked (image 1.tif and 2.tif) in two separate 
windows. 

VII- Mosaicking 
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2- From the main menu of the program choose “Basic tools/Mosaicking” 

 
3- Two options for mosaicking appear in the menu of 

mosaicking: 
A- Pixel Based

B- 

 : In this case mosaicking will be done 
manually. 
Georeferenced 

4- To try the first type, Choose 

: In this case mosaicking will be 
done automatically based on the coordinates of 
the two images. 

“Pixel based”

 

. The “pixel 
based mosaick” dialog box appears. Choose 
“Import/Import files” 
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5- The “Mosaic input files” 

dialog box appears. Highlight 
(choose) the two files (1.tif 
and 2.tif), and press “ok”. If 
you need, you can make a 
subset from this widow.  

 
 
 
 
 
       
  
 
 
6- The “Select mosaic size” box appears. Leave the parameters as 
it is, and press “ok”.  
 
  
 
 
 
 
 
7- The “Pixel mosaic” box appears. Choose 
“options/position entries into grid”. The “Position 
images” box appears. In this box you can choose 
the number of columns and rows suitable for the 
number of images you will mosaic. In our case: 2 
columns and 1 row  are ok. Press “ok”. 
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8-The two images will appear together in the 
mosaicking box. Left click on one of the two images 
and drag it to the correct position relative to the 
other image. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
  
 
 
 
 
9- Press “File/Apply”. The “Mosaic Parameters” box 

appears. Choose “Memory” and press ok. 
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10- The mosaic file will be opened in the “Available band list” box as a memory 

layer. 
11- Open the mosaic in a new display. If it is ok, you can save it.   
 
 
  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Page 96



###-

 

Mosaicking using the second option 
“Georeferenced” 

 
1- Open the two images (1.tif and 2.tif) as 

described before. 
 
2- Select  
   “Basic tools/mosaicking/Georefernced”. 
 
 
 
 
3- The “map based mosaic” box appears. Select “Import/Import files”. 
 
 
 
 
 
 
4- The “mosaic input files” box appears. Choose the two 

file to be mosaiced and press  ok. If you need,  you 
can make a subset at this window  
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5- The two image will be opened and they 

are mosaiced automatically. 
 
 
6- Follow the steps 9-11 explained before. 
 

Page 98



There are two methods for registration: 

VIII- REGISTRATION (georeferencing-rectification) 
 
The process of registration is to define the coordinates for a satellite image or a map of 
undefined coordinates (i.e. there is no header file for the image). 

A. Image to image registration: by defining ground 
control points (GCPs) in the unregistered image and 
obtaining the coordinates of these points based on 
the comparison with the registered image or map. 

B. Image to map registration: by locating ground 
control points (GCPs) in the unregistered image 
where these points have previously known 
coordinate values. The coordinate values are 
entered manually to the software.  

A- Image to image registration:
1- Open the unregistered image (unregistered image.tif) 

in ENVI .  

  

 
2- Open a new display and load the registered image 

(TM-742.tif) in the new display. 
   

 
3- Now you have the two images opened in two separate displays. 

- 
- 

The unregistered image (unregistered image.tif)  in display 1. 
The registered image (base image-TM-742.tif) in display 2. 
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 4- From the main menu of ENVI, open  “Map/Registration/Select GCPs: image to image”. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
5- The “image to image” box appears. Choose  
     Display2   for base image (registered image-TM-742.tif)  
     Display1 for Warp image (unregistered image-unregistered image.tif) 

Press “ok”. The displays must be selected correctly; otherwise the 
whole process will be incorrect.   

 
 
 
6- The “Ground Control Point Selection” box appears. Press 

on a point in “display 1” and on the same point in “display 
2”. The two points will be recorded in the “Ground 
Control Point Selection” box. Press “add point” button to 
fix the first (GCP). You can accurately mark the GCPs using 
the zoom window

 

. In locating the GPSs, there is no 
problem to start with any of the displays. 

 
7- Repeat the same process to fix  4  control points at least. After locating each point you must 

press “add point”. The chosen points are better to be away from each other as possible and 
close to the borders of the image as possible.  The greater the number of GCPs, the more 
accurate will be the registration process.  
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8- Press “show list” button to see the table of points 

you added.  
 
 
 
 
 
 
 
 
 
 
9- In this table (after the addition  of 5 points)

a- Highlight this point in the list. 

 you can see the value of the error in placement 
of the GCPs. A Point of high error can be corrected as follows: 

b- Reposition the point in the two 
images to a more accurate 
position.  

c- Press “update” button to inter the 
new values for this point. 

d- If the error still high the point 
must be deleted and replaced by a 
new point.  

 
 
 
 
 
10- If you want to save the data of the control points into 

a text file (to be used later): in the “Ground control 
points selection” box, press “File/Save GCPs to 
ASCII”. The “Output Registration points” box 
appears. Choose the name and location of the 
output file. 
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11- To finish the registration process, press “Options/ Warp 

file”. The “Input Warp image” box appears. 
 
 
 
 
 
 
 
 
 
 

 
 
12- Chose the unregistered image as input file, then 

press “ok” . 
 
 
 
 
 
 
 
 
13- The “Registration Parameters” 

box appears. Select to get the 
results in memory. The resulted 
output file will be loaded into 
the “available band list” box 

 
 
 
 
 
 
 
 
 
 
 
 
 

Page 102



 
14- Load the Warp file (the resulted file) in a new 

display(Display 3). Double click on any part of the image 
window; the “courser location value” box appears. You 
will find that the image has coordinates and projection.  

 
 
 
15- To check for the accuracy or validity of the registration process “Link” the warped image to 

the base image as follows: 
a- In Display 3, press “Tools/Link/Link Displays”. The “Link Displays” box appears 

 
 
 

b- In this box you want to link the warped image 
in display 3 and the base image in display 2. So 
you must cancel the link with display 1 in this 
box. Press on the button in front of Display 1  
to make the selection “NO”. Press “ok”. 
 

c- Now, the two displays are linked together. If 
the registration process is ok, by pressing at 
any point in Display 3, the same point will 
appear in Display 2.  In this way you can 
compare the two images. 

 
 
 
 
16 -If the results are ok, you can save your results from the last opened display (Display 3) 
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B- Image to map registration: 

1- Open the unregistered image (unregistered image.tif) in ENVI .  Open 
“Map/Registration/Select GCPs: image to map”. 

In this method you must have the coordinates of (at least) 4 GCPs. The coordinate values will be 
given to the software to be used in the registration process.  

 
 
 
 

2- The “Image to map registration” box appears, in which you must 
defined the coordinate system of the GCPs that will be given to the 
software. Press “ok”.  

 
 
 
 
 
 
 
 
 
 

3- The “Ground control points selection” 
box appears. 
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4- Mark the position of the control point on the image, and then enter its coordinates in the 
box manually. 

 
4- If the coordinate values to be entered are in geographic coordinates, use the Button 

to change the style of data input 
 
  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
5- Enter the coordinates of at least  4  GCPs.  
 
6- To complete the registration process, follow the steps from 9 to 16 mentioned in the 
previous section.  
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IX- Image classification 

- Data clustering is a mathematical process of classification of any t ype o f data into 
classes; the data in each class are equal or close together in their value. 

- Image classification (spectral clustering) is classifying pixels of a m ultispectral 
image into discrete classes based on the value of pixel reflectance or digital number 
(DN).  

- There ar e t wo main basis of i mage cl assification. The first i s based on st atistical 
methodology only. The second is based on user-defined training classes (user-defined 
small areas defined by the user and used by the software as a base for classification). 

- Unsupervised classification is used to cluster pi xels in a da taset (image) based on 
statistics only, without any  use r-defined t raining cl asses. Two unsupervised

1- ISODATA Classification. 

 
classification techniques are available:  

2- K-Means Classification. 
- Supervised classification

1- Parallelepiped Classification. 

 is u sed to cluster pi xels in a dat aset ( image) i nto classes 
based o n us er-defined training classes (region of interest, RIO). Some po pular 
supervised classification methods available in ENVI are:  

2- Minimum Distance Classification. 
3- Mahalanobis Distance Classification. 
4- Maximum Likelihood Classification.  
5- Binary Encoding Classification. 
6- Spectral Angle Mapper Classification. 
7- Spectral Information Divergence Classification. 

- Some of these supervised classification methods (no.1, 2,  3,  4,  5) are based on  the 
training classes (region of interest, RIO). T he di fference between t hem i s the 
algorithm us ed i n t he clustering calculation.  Methods (6, 7)  are bas ed on w hat i s 
known as “spectral library”. These libraries are available in ENVI and represent the 
reflectance of minerals, rocks or vegetation types that can be used for minerals, rocks, 
or vegetation detection and classification.  
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IX-A- Unsupervised Classification 

1. From the ENVI main menu bar, open the original image to be classified. 
A- Using ISODATA Classification  

2. From the ENVI main menu bar, select Classification → Unsupervised → IsoData. 
The Input File dialog appears. 

3. Select an i nput file (the i mage t o be cl assified), then cl ick OK. T he IS ODATA 
Parameters dialog appears. 

4. Enter the minimum and maximum Number of Classes you want. ENVI uses a range 
for the number of classes because the ISODATA algorithm splits and merges classes 
based on input thresholds and does not keep a fixed number of classes. 

 
 
 
 
 
 
 
 
 
 
 

 
5. Enter the m aximum n umber o f i terations in t he Maximum Iterations field and a 

change threshold (0-100%) in the Change Threshold % field.  
Iteration is the repetition of the classification process to improve the mean value of 
each cl ass a nd cl ass limits. Threshold

6. Enter the minimum number of pixels needed to form a class in the Minimum # Pixels 
in Class field. If there are fewer than the minimum number of pixels in a class then 
ENVI deletes that class and the pixels placed in the class(es) nearest to them. 

 is the nu mber o f pi xels (in per cent) bel ow 
which t he cl assification pr ocess stops. It means that t he cl ustering pr ocess ends 
when t he num ber o f pi xels i n each  cl ass changes by a per cent l ess than t he 
threshold value. ENVI uses the change threshold to end the i terative process when 
the nu mber o f pi xels in each  cl ass changes by less than t he t hreshold. The 
classification en ds when ei ther t his threshold is met or  the m aximum nu mber o f 
iterations is reached. 

7. Enter t he maximum class standard deviation ( in DN) i n t he Maximum Class Stdv 
field. If the standard deviation of a class is larger than the defined standard deviation 
then the class is split into two classes. 
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8. Enter the minimum class distance (in DN) between class means and the maximum 
number of merge pairs in the fields provided. 
If the distance between class means is less than the minimum value entered, then 
ENVI merges the classes. The maximum number of class pairs to merge is set by the 
maximum number of merge pairs parameter. 
To se t t he optional st andard deviation t o use ar ound t he cl ass mean and/or t he 
maximum allowable distance error (in DN), enter the values in the Maximum Stdev 
From Mean or Maximum Distance Error fields, respectively.  
If you enter values for both of these optional parameters, the classification uses the 
smaller of the two to determine which pixels to classify. If you do not enter a value for 
either parameter, then all pixels are classified.  

9. Select output to File or Memory. 
10. Click OK. The status bar cycles from 0 to 100% for each iteration of the classifier. 

ENVI adds the resulting output to the Available Bands List.  
11. To display t he r esulted cl assification l oad t he cl assification i mage i n a n ew 

display using the “grey scale” option. 

B- Using K-Means Classification
Practically, the steps used to carry out the K-mean classification in ENVI are similar to 
the isodata classification. The only difference is that the number classes is given a fixed 
value determined by the user. The number of classes in the isodata classification is a 
range between a minimum and maximum values determined by the user. 

  

 
In both types of unsupervised 
classification methods, do the  

1- Use the maximum iteration = 1  
(the default value), and get the 
classified image. 

following: 

2- Use the maximum iteration = 5  
and get the classified image. 

3- Notice the difference between the 
two cases. 

 
 
 
 
 

Page 108



You can to interactively overlay classes on and off on the displayed image: 

Overlaying the classified classes on the original image, Edit class 
names and colors, and Merging classified classes: 

1. F rom the Available Bands List, l oad the original image as a gray sca le image or 
multispectral image.  

2. From the Display group menu bar, select Overlay → Classification. The Interactive 
Class Tool Input File dialog appears.  

3. Select the classified image file within the “Select Input F ile section” of this dialog 
and cl ick OK. The I nteractive C lass Tool a ppears with each  cl ass listed w ith i ts 
corresponding colors.  

 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
4. Click each On check box to change the display of each class as an ov erlay on t he 

original image. 
 5- To edit the class name or color use Options → Edit class colors / names. 
6- To merge two classes or more use Options → Merge classes. 
7. From the Display group menu bar, select File → Save Image As → Image File to 

burn in the classes and output to a new file.  
8. F rom t he Interactive C lass Tool menu bar , s elect File → Cancel to e xit the 

interactive tool.  
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Improving and smoothing the classified image

1. From the ENVI main menu bar, select Classification → Post Classification → 
Majority/Minority Analysis. The Input File dialog appears. 

 (solve t he pr oblem o f 
isolated pixels occurring in other larger classes.): 
There are several methods to solve this problem. Some methods consider the isolated 
pixels as unclassified and others add them to the surrounding class. The most popular 
method is the “majority/minority analysis” technique.  

2. Select the classification image file, then click OK. The Majority/Minority Parameters 
dialog appears. 

3. In the list of classes, select the classes
want to apply the analysis to. If the problem of 

 that you 

isolated pixels is found in all classes, choose all 
classes. 

4. Select the analysis method, by clicking the 
corresponding toggle button. Choose “majority”. 

5. Enter a kernel size. Larger kernel sizes produce 
more smoothing of the classification image. 

6. Select output to File or Memory. 
7. Click OK. ENVI adds the resulting output to the 

Available Bands List.. 
8. Notice if the smoothing process is ok. If not, repeat 

the process with a higher kernel value.  
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ENVI provides annotation tools to put classification keys (legend) on images and in map 
layouts. The classification keys are automatically generated.  

Adding Classification Keys (legend) Using Annotation  

1. F rom t he D isplay g roup m enu bar  of t he cl assified i mage, se lect Overlay →  
Annotation. 

2. F rom the Annotation menu bar, se lect Object → Map Key to start annotating the 
image. You can edit the legend characteristics by cl icking the Edit Map Key Items 
button in the dialog and changing the desired characteristics.  

3. Click once with the left mouse button in the Image window to place the legend in the 
image window.  

4. Click and drag the legend using the left mouse button in the display to place the key.  
5. Click in the display with the right mouse button to finalize the position of the legend.  
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Supervised classification is based on training classes (Regions of interest, ROI) defined 
by the user.  You must prepare the Regions of interest (ROI) before performing 

IX-B- Supervised classification 

supervised
There are many methods for supervised classification. For training, you well apply two 
types :: 

 classification. Each training class (ROI) will represent a certain rock unit.  

1- Parallelepiped Classification. 
2- Mahalanobis Distance Classification. 

Carryout both classifications and notice the difference in the produced classified images 

 
A- Defining Training Classes (Region of interest, ROI) 

 
 
 
 
 
 
 
 
 
 
 

1. Open the original image file in ENVI as usual. 
To draw an ROI:  

2. Open the ROI tool from any of the following locations: 
o From the Display group menu bar, select Overlay → Region of Interest. 
o From the Display group menu bar, select Tools → Region of Interest → ROI Tool. 
o From the ENVI main menu bar, Basic Tools → Region of Interest → ROI Tool. 

The ROI Tool dialog appears. 
3. Select whether to use the Image, Scroll, or Zoom window to draw the ROIs. 
4. From the ROI Tool dialog menu bar, select ROI_Type  to choose the type of the 

shape you want to draw. Select one of the following options: Polygon, Polyline, 
Point, Rectangle, or Ellipse. 
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5. Move your mouse to the window you have chosen in step 3, and left click on the 
image to draw your shape. After drawing the shape right click once to close the 
shape, and right click a second time to fix the shape. You can draw several shapes in 
the same class. The class name and color are defined automatically, that can be 
changed later by editing as explained before in the previous lab.. 

6. To create a new class (region), press “New Region” button, and draw your new 
shapes. You can create new classes as many times as you want. 

7. To delete a class (region), select that class in the classes list (in the ROI column) and 
press the button “delete ROI”. 

8. To delete a part of the class, select the class in the classes list and press “goto” 
button several times to locate the shape you want to delete. In the image window, a 
rectangle appears on the shape to be deleted and moved to another shape each time 
you press “goto”. After locating the shape to be deleted press the “delete part.” 
Button. 

9. To merge two or more classes (regions) into one class, select Options → Merge 
Regions. The Merge ROIs dialog appears with two lists of all defined regions.  
a- Under Choose Base ROI to Merge, select the name of the base class (the class 

where other classes will be merged on). 
  b- Under the Choose ROIs to Merge list, select the names of the classes to merge 

into the base class. 
c- To remove the original individual classes being merged after they are merged   

Click the Delete Merged ROIs?. The color of the other ROIs change to that of 
the base ROI and the other names are removed from the ROI Tools dialog table. 

D- Click OK. 
10.  After you finished the plotting of classes, save the training classes into  a ROI file  

from the RIO Tool menu  File→ save RIOs.    
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1. From the ENVI main menu bar, select Classification → Supervised → 
Parallelpiped. The Input File dialog appears. 

B- Applying Parallelepiped Classification 

2. Select an image file to be classified then click OK. The Parallelepiped 
Parameters dialog appears.  

3. If an error message appears “there are no ROIs associated with this input file 
to classify with”, this indicates that the ROI file is not recognized. Press the 
open button (at the lower part of the dialog box), → ROI File, and then select the 
ROI file you previously prepared, press open then ok. Now you can select the 
image file to be classified again and the Parallelepiped Parameters dialog 
appears.   

 

 

 

 

 

 

 

 

 

4. In the Select Classes from Regions list, select any number of classes or all 
classes as training classes. The ROIs listed are derived from the available ROIs 
in the ROI file.  

5. Select one of the following thresholding options from the Set Max stdev from 
Mean area: 

o None: Use no standard deviation threshold.  

o Single Value: Use a single threshold for all classes. Enter a value in the Max 
stdev from Mean field to designate the value of standard deviations to use 
around the mean. 

o Multiple Values: Enter a different threshold for each class. Do not use this 
option at the present time

6. Select classification output to File or Memory. 

. 

Page 114



7. The Output Rule Images? option: if enabled an intermediate file (rule image file) 
is produced in the “available band list”. This file can be used in post classification 
processes. Do not enable this option at the present time

8. Click Preview to see a classification image before getting a final product. You 
can change the parameters as needed and click Preview again to update the 
display. 

.  

9. Click OK. ENVI adds the resulting output classified image to the “Available 
Bands List”. To view the resulted image, view it in a new display on the “grey 
scale” option.  

1. From the ENVI main menu bar, select Classification → Supervised → 
Mahalanobis Distance.The Input File dialog appears. 

C- Applying Mahalanobis Distance Classification  

2. Follow the same steps used in the previous classification. Do not put a value for 
the “maximum distance error”, unless you are not convinced with the resulting 
classified image. 
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